Página 1 de 1

Error el actualizar [Solucionado]

Publicado: 16 Oct 2019, 01:01
por wonder

Tengo un foro, actualmente poco movimiento y estoy centrado en otro, más grande, a ver si puedo pasarlo a este sistema...

No obstante, tampoco quiero dejar el otro, pero hay veces que nos faltan manos y horas a lo largo del día o la noche :)

Vi que tenia update, finalmente decidí, saltaba 2 versiones pero...no recuerdo de que versión saltaba a cual.

Bajo panel puedo ver que, me indica estoy en 3.2.5, así que existen dos posibilidades:
Que quisiese actualizar de 3.2.3 a 3.2.5 o que quisiera de 3.2.5 a 3.2.7 (que no creo sea este último...)
Aunque creo, carece de importancia para mi problema.

Lo hice por el procedimiento que, una vez la actualización a analizado, te indica archivos a bajar, en ese punto se me para y me indica esto:

Information
Unable to guess the mime type as no guessers are available (Did you enable the php_fileinfo extension?)

He buscado info, por lo que he visto hay que tocar algo del php.ini...pero no hay una info aclaratoria, lo que he probado, no resolvió.

Estoy en un server compartido, pero tengo acceso cpanel aunque no, ssh.

En breve lo migraré a un VPS mio, pero de momento, lo dejo ahí.

Sabéis por dónde pueden ir los tiros?

Agradecido de antemano.


Error el actualizar

Publicado: 16 Oct 2019, 19:04
por AbaddonOrmuz

Intenta actualizar con el paquete completo, en lugar de la actualización automática que es la que parece que estas usando.

Con ella perderás modificaciones que hayas hecho, sin embargo no tendrás el problema que comentas.

https://phpbb-es.com/foro/viewtopic.php?t=42198

wonder escribió:
16 Oct 2019, 01:01

Unable to guess the mime type as no guessers are available (Did you enable the php_fileinfo extension?)

Habilita la extensión fileinfo desde las opciones de PHP (en el selector de versión) en cPanel, Plesk o el que te proporcione tu servidor compartido.

Si es en tu VPS, checa que exista fileinfo.so dentro de /usr/lib/php/modules/

Código: Seleccionar todo

# Requiere mlocate
sudo updatedb
locate -e fileinfo.so

Error el actualizar

Publicado: 16 Oct 2019, 20:57
por wonder

Gracias por la respuesta.
No he recibido el mail notificación de nueva respuesta y por ello me demoré.

No, no esta en VPS (de momento) y efectivamente, es la actualización automática, por ello, porque tengo alguna modificación (en el style) y no quería perderla...

Dicho ello, ya que tengo el upgrade a mitad de paso y a salido una nueva actualización, podría usar la completa en el punto que estoy usando la última publicada?

La extensión fileinfo es para la automática, corrígeme si me equivoco.

Gracias y un saludo!


Error el actualizar

Publicado: 16 Oct 2019, 22:10
por AbaddonOrmuz
AbaddonOrmuz escribió:
16 Oct 2019, 19:04

Dicho ello, ya que tengo el upgrade a mitad de paso y a salido una nueva actualización, podría usar la completa en el punto que estoy usando la última publicada?

Apenas he usado un par de veces a lo mucho la actualización automática, no recuerdo si para cuando te pide remplazar archivos la base de datos ya habrá sido actualizada.

Lo más importante es la base de datos, y las actualizaciones (del paquete completo al menos) contienen todas las anteriores, se irán aplicando cambios de todas las versiones intermedias para evitar inconsistencias.

Si la base de datos ya fue actualizada, aún cuando los archivos no se hayan actualizado aún, puedes usar el paquete completo de la versión más reciente y continuar con el proceso.

En teoría, detectaría que la base de datos ya fue actualizada hasta la versión que te quedaste y continuaría haciendo cambios en ella en caso de ser necesario.

wonder escribió:
16 Oct 2019, 20:57

La extensión fileinfo es para la automática, corrígeme si me equivoco.

Al parecer sí, o al menos jamás he necesitado de ella usando el paquete completo, ni siquiera tengo esa extensión en mis servidores :P


Error el actualizar

Publicado: 17 Oct 2019, 00:36
por wonder

Gracias!

Voy a probar habilitando la extensión por si no hubiese actualizado (o si ) la bd, por aquello de subir hasta esa y ya si eso la completa.

Llegado aquí he estado buscando info por "san google" para habilitarla, es un server compartido, pero tengo cpanel, a través del cpanel no puedo/tengo opción de habilitar dicha extensión, las indicaciones que he encontrado por internet son de versiones anteriores de cpanel y php.

He probado unas líneas en el htaccess pero no dieron resultado.

Mañana con calma miraré más, si acaso en el php.ini a ver si hay suerte.

Si todo va mal, me iría a la completa, pero tengo editados 2 o 3 archivos del style que ahora....pues no recuerdo cuales son... :?:
Si tiro a la completa y no subo la carpeta style, cagadita verdad?

Hace tiempo leí un poco por encima, pero al final no me puse, no recuerdo exactamente pero era algo del tipo...
Se crea un "sub estilo" ahí hacemos los cambios, actualizamos con completa, los cambios se mantienen pero se actualiza... (jooo, que mala memoria tengo) debí estudiar eso y ahora no estaría en esta tesitura...xD

Gracias y saludos!


Error el actualizar  Tema Solucionado

Publicado: 29 Oct 2019, 15:04
por wonder

Finalmente pude solventarlo.
Tenía dos medios:
1-Descargarme el zip con solo los archivos modificados.
2-Más tarde vi que en la carpeta /Store/ esta el zip generado con los archivos, tan solo necesitaba bajarla, descomprimir y subir archivos.

Como en la instalación se "quedó" en el punto de descarga (algo que no hacía) tuve que "resetear" instalación, para ello eliminé el archivo de /Store/install_config.php
De ese modo, ya pude acceder a la actualización y actualizar solo base de datos, que era lo que únicamente hacía falta.

Ya esta actualizado a 3.2.8 :)

Eso si, ahora tengo otros problemas(que creo antes del upgrade ya los tenía) pero esos, en otro hilo...

Gracias y saludos!