Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Ayuda - Error Phpbbconnector

Foro de phpBB2 Avanzado no para dudas de Soporte General.
Cerrado

0
No hay votos
 
Votos totales: 0

Avatar de Usuario
edyar
Observador/a
Mensajes: 1
Registrado: 15 Feb 2008, 14:51

Ayuda - Error Phpbbconnector

#1

Mensaje por edyar » 04 Mar 2008, 19:38

Ayuda

Estoy integrando Joomla y PhpBB con "Community Builder" y me sale el siguinte:

Warning: require_once(/configuration.php) [function.require-once]: failed to open stream: No such file or directory in /home/dys/public_html/components/com_comprofiler/plugin/user/plug_phpbbconnector/phpbbgui.php on line 27

Fatal error: require_once() [function.require]: Failed opening required '/configuration.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dys/public_html/components/com_comprofiler/plugin/user/plug_phpbbconnector/phpbbgui.php on line 27


Me habia contestado algo "Sergini9384" pero se borro.??




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
gusimaldito
Observador/a
Mensajes: 4
Registrado: 12 Dic 2006, 12:47

Re: Ayuda - Error Phpbbconnector

#2

Mensaje por gusimaldito » 11 Mar 2008, 12:22

Ayuda

Estoy integrando Joomla y PhpBB con "Community Builder" y me sale el siguinte:

Warning: require_once(/configuration.php) [function.require-once]: failed to open stream: No such file or directory in /home/dys/public_html/components/com_comprofiler/plugin/user/plug_phpbbconnector/phpbbgui.php on line 27

Fatal error: require_once() [function.require]: Failed opening required '/configuration.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dys/public_html/components/com_comprofiler/plugin/user/plug_phpbbconnector/phpbbgui.php on line 27


Me habia contestado algo "Sergini9384" pero se borro.?? Hola, yo estoy en el mismo caso que tú...


El problema es que esos ficheros no existen dentro de components/comprofiler, de hecho ni siquiera existe el directorio 'user'.

Supongo que estás siguiendo los pasos de la guía de integración de joomla 1.0.X con phpBB, en mi caso intento integrarlo con joomla 1.5, y hasta aquí todo había ido bien.
Quizás el problema es que no se ha instalado correctamente el componente comp_profiler del Community Builder.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
gusimaldito
Observador/a
Mensajes: 4
Registrado: 12 Dic 2006, 12:47

Re: Ayuda - Error Phpbbconnector

#3

Mensaje por gusimaldito » 11 Mar 2008, 15:15

Ayuda

Estoy integrando Joomla y PhpBB con "Community Builder" y me sale el siguinte:

Warning: require_once(/configuration.php) [function.require-once]: failed to open stream: No such file or directory in /home/dys/public_html/components/com_comprofiler/plugin/user/plug_phpbbconnector/phpbbgui.php on line 27

Fatal error: require_once() [function.require]: Failed opening required '/configuration.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dys/public_html/components/com_comprofiler/plugin/user/plug_phpbbconnector/phpbbgui.php on line 27


Me habia contestado algo "Sergini9384" pero se borro.?? Hola, yo estoy en el mismo caso que tú...


El problema es que esos ficheros no existen dentro de components/comprofiler, de hecho ni siquiera existe el directorio 'user'.

Supongo que estás siguiendo los pasos de la guía de integración de joomla 1.0.X con phpBB, en mi caso intento integrarlo con joomla 1.5, y hasta aquí todo había ido bien.
Quizás el problema es que no se ha instalado correctamente el componente comp_profiler del Community Builder. Ok, ya lo tengo resuelto...

Os dejo una descripción del problema y solución...

El problema es que al abrir el ?Plugin control panel?, nos abre una nueva ventana y nos da una serie de errores...

Estos errores son porque dentro de la página phpbbgui.php se usa una variable llamada '$phpbb_root_path' que se supone tiene el path al directorio donde has instalado el foro.

En mi caso, he instalado Joomla 1.0.15 dentro del Xampp y mi ruta es:

c:\Archivos de programa\xampp\htdocs\joomla\

y la del foro por tanto:

c:\Archivos de programa\xampp\htdocs\joomla\foro\

Pero por algún motivo, no coge bien ese path... así que la solución pasa por asignarle uno el valor bueno a la variable con un:


$phpbb_root_path = 'c:/Archivos de programa/xampp/htdocs/joomla/foro/';

No es muy ortodoxo, pero funciona...

Además de en este archivo, me ha dado error en estos otros:

common.php
db.php
phpbbconnector.php

Y la solución es la misma, vemos en qué linea está dando el error y ponemos el path.

Un saludo y gracias.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado

Volver a “phpBB 2 Avanzado, integración, etc.”