Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Actualizar de 3.0.14 a 3.2.0

Foros donde podréis dejar vuestras dudas sobre phpBB 3.0.x
r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Actualizar de 3.0.14 a 3.2.0

#1

Mensaje por r12espana » 23 May 2017, 00:01


Datos de Soporte - Inicio

URL: www.clubr12espana.es/foro
Estilo(s) usuado(s): prosilver2_modificado
MODs/Extensiones instaladas: Ninguna
Versión de phpBB: 3.0.14
Tu conocimiento: Conocimiento básico
Servidor: Hosteurope
Es una actualización desde otra versión: actualizado desde 2.0.1
Es una conversión desde otro tipo de Foro: no

Datos de Soporte - Fin

No consigo actualizarlo y me estoy volviendo loco, si alguien puede hacerlo por mi, que me diga sin problemas su tarifa... he mirado tutoriales, sigo los pasos pero o bien me da error al actualizar las bases de datos o no me deja elegir la carpeta donde tengo instalado el foro para convertirlo... ya no se que hacer, estoy desesperándome...




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
canidev
Moderador
Mensajes: 537
Registrado: 30 Jun 2011, 17:06
Nombre real: Iván
Género:
Edad: 32
Contactar:

Re: Actualizar de 3.0.14 a 3.2.0

#2

Mensaje por canidev » 23 May 2017, 01:33

Hola

En estos casos sería de ayuda saber que error te da exactamente para poder ayudarte.

Te dejo este tutorial, a ver si te sirve de ayuda.
https://www.youtube.com/watch?v=HCPMIhUZDow

Si aún así sigues teniendo problemas y quieres que lo hagamos nosotros, puedes entrar en la zona premium y abrir un hilo para que te demos presupuesto.

Saludos


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#3

Mensaje por r12espana » 23 May 2017, 15:13

He tenido varios problemas, el primero que mi servidor tenía una versión de PHP muy antigua y no me dejaba... pedi el cambio y ahora puedo seleccionar el PHP que quiera, lo dejé en 5.4 para probar...
Intenté los tutoriales y es que me daba varios fallos, no los he apuntado.
Esta noche lo probaré de nuevo, y sacaré capturas de pantalla con los errores, y a ver si me podéis ayudar con ellos.
Me gustaría dar con ello, por que llevé el foro desde un phpbb2 subiéndolo versión a versión hasta el 3.0.14 pero ahí lo dejé, y será la falta de práctica ya...
Miraré el vídeo detenidamente y a ver si doy con ellos, os mantengo informados.

P.D. no lo puse arriba por que no me acordaba, tengo un mod instalado de captcha, espero que no sea eso, a ver si se desinstalarlo...

Saludos.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#4

Mensaje por r12espana » 23 May 2017, 15:22

Añado un error que me sale ahora en cabezera cuando entro en subforos restringidos a ciertos grupos... en los foros abiertos no sucede... antes de intentar actualizar tampoco salian estos errores, algo ha cambiado en la base de datos, y no tengo copia de seguridad antigua... tonto de mi. Ahora si que hago una copia cada vez que intento hacer algo...

Código: Seleccionar todo

[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
Última edición por ThE KuKa el 23 May 2017, 22:53, editado 1 vez en total.
Razón: Añadir BBCode Code.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 611
Registrado: 14 Ene 2017, 22:18
Nombre real: Alfredo
Ubicación: /dev/null
Género:
Contactar:

Re: Actualizar de 3.0.14 a 3.2.0

#5

Mensaje por AbaddonOrmuz » 23 May 2017, 17:23

Te muestra esas advertencias de preg_replace() porque el fichero usa un modificador que ya quedó obsoleto en tu nueva versión de PHP, esto se debería solucionar cuando actualices a phpBB 3.2

Te recomendaría actualizar a PHP 5.6 como mínimo, aunque lo recomendable sería actualizar a 7.0, las versiones anteriores a 5.6 ya no recibirán ninguna actualización de seguridad.

https://secure.php.net/supported-versions.php
Algunas de mis extensiones: [ Imgur | Metadatos SEO | Markdown ]
Checa todas mi extensiones
Usuario de Arch Linux


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#6

Mensaje por r12espana » 23 May 2017, 21:49

Ok, he actualizado a PHP 7.1, el el último que me permite el hosting.

Estoy tratando de limpiar la base de datos mediante el STK, y me da este error...

Código: Seleccionar todo

 Parse error: syntax error, unexpected 'new' (T_NEW) in /home/dfakkdge/public_html/foro/includes/captcha/plugins/phpbb_captcha_qa_plugin.php on line 104
Última edición por ThE KuKa el 23 May 2017, 22:55, editado 1 vez en total.
Razón: Añadir BBCode Code.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#7

Mensaje por r12espana » 23 May 2017, 21:52

Se me ha ocuurido la "brillante" idea de borrar el phpbb_captcha_qa_plugin.php y me deja empezar el proceso, pero me da otro error ahora...

Código: Seleccionar todo

 Parse error: syntax error, unexpected 'new' (T_NEW) in /home/dfakkdge/public_html/foro/stk/includes/database_cleaner/database_cleaner_controller.php on line 429
Última edición por ThE KuKa el 23 May 2017, 22:55, editado 1 vez en total.
Razón: Añadir BBCode Code.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
andares
Moderador
Mensajes: 1179
Registrado: 18 Nov 2008, 03:32
Nombre real: Pedro
Ubicación: Barcelona
Género:
Edad: 53
Contactar:

Re: Actualizar de 3.0.14 a 3.2.0

#8

Mensaje por andares » 23 May 2017, 21:56

Cambia de nuevo la versión de PHP a 5.6 desde el panel de control de tu hosting, todos esos errores son por que 3.0.14 no es compatible con PHP 7.X


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#9

Mensaje por r12espana » 23 May 2017, 21:58

Ahora si! Muchas gracias... va poco a poco, pero va :)

A ver si no me atasco en ningún paso más...


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#10

Mensaje por r12espana » 23 May 2017, 22:17

He limpiado la base de datos, borrado todo del server menos config.php, files, images y store... y ya usando el install, me sale este error...
Adjuntos
update.JPG


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#11

Mensaje por r12espana » 23 May 2017, 22:27

Como no sale de esa pantalla, he intentado empezar otra vez, ahora me sale esto al intentar actualizar la base de datos...

Código: Seleccionar todo

The installer detected a timeout

The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.

En el php.ini tengo esto...
; cPanel-generated php ini directives, do not edit
; Manual editing of this file may result in unexpected behavior.
; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)

allow_url_fopen = Off
allow_url_include = Off
asp_tags = Off
display_errors = On
enable_dl = Off
file_uploads = On
max_execution_time = 3600
max_input_time = 3600
max_input_vars = 1000
memory_limit = 32M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php56"
upload_max_filesize = 32M
Última edición por ThE KuKa el 23 May 2017, 22:56, editado 1 vez en total.
Razón: Añadir BBCode Code.


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
ThE KuKa
Administrador
Mensajes: 8930
Registrado: 04 Ene 2004, 19:27
Nombre real: Raúl
Ubicación: Terrassa
Género:
Edad: 45
Contactar:

Re: Actualizar de 3.0.14 a 3.2.0

#12

Mensaje por ThE KuKa » 23 May 2017, 22:58

Por favor, usar los BBCodes disponibles, en especial al publucar codigo.

Saludos.
Raul [ThE KuKa] en phpBB
Jr. Extension Validator - Jr. Styles Validator - Style Customisations - Translator - International Support Team


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#13

Mensaje por r12espana » 24 May 2017, 00:43

Bueno, ya llego hasta aquí... el problema es que tenía elegido un catpcha que no es por defecto... pero ahora ya si que stá todo bien... estilo prosilver, lenguaje british, limpieza de base de datos... pero en el update se me queda siempre en este paso que adjunto en la imagen... y si actualizo ya me pone lo de"The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI."
Adjuntos
update2.JPG


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Avatar de Usuario
AbaddonOrmuz
Moderador
Mensajes: 611
Registrado: 14 Ene 2017, 22:18
Nombre real: Alfredo
Ubicación: /dev/null
Género:
Contactar:

Re: Actualizar de 3.0.14 a 3.2.0

#14

Mensaje por AbaddonOrmuz » 24 May 2017, 04:25

Puedes incrementar el max_execution_time desde cPanel o pidele a tu hosting que lo haga por ti.
Algunas de mis extensiones: [ Imgur | Metadatos SEO | Markdown ]
Checa todas mi extensiones
Usuario de Arch Linux


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

r12espana
Observador/a
Mensajes: 11
Registrado: 22 May 2017, 23:38
Nombre real: David

Re: Actualizar de 3.0.14 a 3.2.0

#15

Mensaje por r12espana » 24 May 2017, 08:03

Ya lo tengo en 36000 en el php.ini

Pongo aquí tal y como tengo ahora el php.ini

Código: Seleccionar todo

allow_url_fopen = Off
allow_url_include = Off
asp_tags = Off
display_errors = On
enable_dl = Off
file_uploads = On
max_execution_time = 360000
max_input_time = 360000
max_input_vars = 360000
memory_limit = 1280M
session.gc_maxlifetime = 144000
session.save_path = "/var/cpanel/php/sessions/ea-php56"
upload_max_filesize = 1024M


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado

Volver a “Foros de Soporte 3.0.x”