Recordad que para pedir soporte alguno, debéis facilitar los datos de soporte oportunos por favor, mirad aquí y leer las Normas generales del foro, esto nos servirá de ayuda para dar el mejor soporte..

Gracias.

La Administración de phpBB España.

Actualización de 3.07PL1 a 3.0.14 para luego actualizar 3.1 -> 3.2

Foros donde podréis dejar vuestras dudas sobre phpBB 3.0.x
Cerrado

0
No hay votos
 
Votos totales: 0

virusbcn
Observador/a
Mensajes: 13
Registrado: 18 Abr 2017, 21:22
Nombre real: virusbcn

Actualización de 3.07PL1 a 3.0.14 para luego actualizar 3.1 -> 3.2

#1

Mensaje por virusbcn » 22 Abr 2017, 13:28


Datos de Soporte - Inicio

URL:www.tmax.es/forum (del sitio en cuestión)
Estilo(s) usuado(s): RedSilver(del sitio en cuestión)
MODs/Extensiones instaladas: (en el sitio en cuestión)
Versión de phpBB: 3.07PL1(del sitio en cuestión)
Tu conocimiento: Soy técnico de sistemas pero novato en PHPBB
Servidor: (del sitio en cuestión, si es de pago, gratuito, etc.)
Es una actualización desde otra versión: Lo desconozco (especificar versión anterior y versión de actualización)
Es una conversión desde otro tipo de Foro: NO (especificar sistema de foro anterior y versión del nuevo)

Tengo problemas para actualizar a 3.0.14 que es el primer paso que tengo que hacer según veo en todas las guías para actualizar a 3.2, sino me equivoco los pasos serían actualizar a 3.0.14 y luego a 3.1 y después a 3.2

He probado a actualizar y directamente a subir entera la versión 3.0.14 borrando config.php, /files y /store sino recuerdo mal y al intentar actualizar la base de datos con .../install/database_update.php me da este error y de ahí no consigo pasar:

Actualizando base de datos a la última versión estable

Tipo de base de datos :: mysql4
Versión previa :: 3.0.7-PL1
Versión actualizada :: 3.0.14


Error


Añadir que he cambiado los permisos del config.php a 666 y he revisado el resto de permisos y están todos correctos, poco más se me ocurre mirar, a ver si me podéis dar un empujoncito :hai:




Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

virusbcn
Observador/a
Mensajes: 13
Registrado: 18 Abr 2017, 21:22
Nombre real: virusbcn

Re: Actualización de 3.07PL1 a 3.0.14 para luego actualizar 3.1 -> 3.2

#2

Mensaje por virusbcn » 22 Abr 2017, 15:05

Bueno, no sé si he hecho bien pero os cuento....

He visto que poniendo el foro en inglés me ha salido el error de que la bbdd estaba obsoleta (mysql4) y debía actualizarla a mysql5 (que es el motor que hay ahora), he estado buscando y he visto que hay un Support toolkit que entre otras muchas opciones tiene la de hacer el "upgrade" y en el paso 13 me da este error: (también he probado a ejecutar database cleaner, limpiar caches, etc.)


Error General
SQL ERROR [ mysql4 ]

Incorrect string value: '\xF0\x9F\x98\x95Gr...' for column 'draft_message' at row 50 [1366]

SQL

ALTER TABLE foro_drafts MODIFY draft_id mediumint(8) UNSIGNED NOT NULL auto_increment, MODIFY user_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, MODIFY topic_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, MODIFY forum_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, MODIFY save_time int(11) UNSIGNED DEFAULT '0' NOT NULL, MODIFY draft_subject varchar(255) DEFAULT '' NOT NULL COLLATE utf8_bin, MODIFY draft_message mediumtext NOT NULL COLLATE utf8_bin, DEFAULT CHARSET=utf8 COLLATE=utf8_bin

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: stk_msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/stk/tools/support/mysql_upgrader.php
LINE: 337
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/stk/tools/support/mysql_upgrader.php
LINE: 70
CALL: mysql_upgrader->_run_result()

FILE: [ROOT]/stk/index.php
LINE: 293
CALL: mysql_upgrader->display_options()


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

virusbcn
Observador/a
Mensajes: 13
Registrado: 18 Abr 2017, 21:22
Nombre real: virusbcn

Re: Actualización de 3.07PL1 a 3.0.14 para luego actualizar 3.1 -> 3.2

#3

Mensaje por virusbcn » 22 Abr 2017, 16:28

Bueno, pues pasé el mysql_upgrader.php de mi versión, volví a probar a actualizar y ... voilà !!!! ya tengo la 3.0.11 y luego la 3.0.14 instalada, ahora a por la 3.1 :rock:


Enlace:
BBCode:
HTML:

Ocultar enlaces al mensaje
Mostrar enlaces al mensaje

Cerrado

Volver a “Foros de Soporte 3.0.x”